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THE SOFTWARE  

 

You will need the following:  

 

1. ZModeler v.1.07b - To make your model car. It’s free, find it at www.zmodeler2.com.  

2. Adobe Photoshop - To make textures (paintjobs) for your models. If you don't have Photoshop, you 

can download The Gimp for free.  

3. MS Paint - Loads much faster than Photoshop and is used for some shortcuts.  

4. MS WordPad/Notepad - Used to edit tuning files for the car.  

5. MS Sound Recorder or GoldWave - If you want custom engine sounds and such. Not absolutely 

necessary.  

6. WinRAR - To package everything together in the end.  

7. Midtown Madness 2 - To test out and have fun with your car!  

 

If you have all of the above with the exception of #5, you're ready.  

 

 

LESSON 1: BLUEPRINTS  

 

Choose a car you want to model. Since you're a beginner, it’s advised to pick a boxy car. For this 

tutorial, I've chosen the Jeep Grand Cherokee (2003). You can just copy it. 

 
 

 

 

Also since you're a beginner, you should use blueprints. Some good sites to find blueprints are 



http://www.the-blueprints.com/index.php?blueprints/ , http://carblueprints.narod.ru/index.htm , 

and http://www.smcars.net/forums/ (you'll have to sign up to view them at SMCars).  

There are good blueprints and not so good blueprints. You can quickly test out your set of blueprints 

to see how good or bad they are.  

 

 

Test:  
Open up the blueprint in MS Paint. Making sure the side view and front view are at the same level 

(see green lines below), connect features like the top of the headlights from side view to front view 

(see red lines below). You can also check side and back views. If the red lines are perfectly horizontal, 

it means the blueprints are MOST PROBABLY (98%) good. Also, look at the front view and trace the 

outlines of the hood (see blue lines below). They should taper downwards. If they taper upwards or 

don't taper at all (parallel), the blueprint is NOT COOL!!! Also, good blueprints come with a top view, 

but not always necessary.  

 

EDIT: Take a look at the side view. On good blueprints, you should see more than just the headlights 

on the front end, including some of the grille and on the rear end you should see more than just the 

tail-lights. This is because most cars don't have flat fronts or backs and so you should be able to see 

some details beyond the headlights and tail-lights in the side view.  

 

NOTE: Before you test out your set of blueprints, you must be sure that all the heights and widths 

match up. The heights of the front, back and side views should be the same. The widths of the front, 

back and top views should be equal. It’s obvious that you shouldn't compare the blueprints yet, say, if 

the back view is twice as large as the front.  

 

 

Example of a fair blueprint:  

 
 

 



Example of a poorly done blueprint:  

 
 

 

 

Now we need to prepare the blueprint for putting into ZM (ZModeler). Simply make new images 

containing only ONE view each and make sure it’s centered. The images should be saved as bitmap 

(.bmp) or targa (.tga) formats. If you want more details on how to carry out this step, read below. 

Otherwise, you can skip to the next lesson.  

 

 

Open up your blueprint in Photoshop. ROUGHLY select the side view using the 

rectangular marquee tool and copy (by pressing Ctrl+C),  

 
 



 

Then go to File>New... and a box will appear. Don't change anything, just press OK 

and then paste (by pressing Ctrl+V) the image there. Now use the Magic Wand tool 

to select the area outside of the side view of the car and then right-click it, go to 

Select Inverse.  

 
 

 

Only the side view should be selected now and no white space around it. Copy and 

Paste to another new document, you should get something like this:  

 
 



 

Go to Image>Canvas size... and you'll get the box shown below with the same 

numbers if you did everything right.  

 
 

 

The image should have dimensions such as 128, 256, 512, 1024 ...etc. So pick the 

next highest number than shown for current width and height. In this case, change 

width to 512 and height to 256. DO NOT TOUCH THE ANCHOR, it should be at the 

center box. Paint the transparent area white. Your final image of the side view is 

centered on the canvas and should like this:  

 
 

 

Finally, save it by going to File>Save as... and save it as either .bmp or .tga. I choose 

.bmp because the file size will be smaller and there is nothing transparent on my 

canvas.  



 
 

Repeat for front, back and top views. 
 

 

Few notes:  

-When preparing the top view, it should be oriented so that the headlights face down and taillights 

face up, just like in the blueprint I found for the Jeep Grand Cherokee. Otherwise, select the top view 

and go to Edit>Transform>Rotate[degree of your choice] to rotate it to the proper orientation.  

 

-Sometimes, blueprints are very large in dimensions. When you get to the step where you are about 

to increase the canvas size, resize your image first by going to Image>Image size and make sure 

constrain proportions is checked. Ideally, you want the width of the side view to be 512 pixels. That 

also means that the height of your top view (if you have one) will also be 512 pixels. Remember, when 

changing the front and back views, their dimensions should match. Also their heights will equal the 

height of the side view and their widths should equal the width of the top view.  

 

-You also probably want some photos of your car for reference. The lighting and coloring on photos 

tells you depth of the car, where there are curves, how much of a curve and other such details. Collect 

some dynamic shots from sources like Google Image, Yahoo Autos, Motorcities or even the car 

maker's site.  

 

That’s it for now I think. Next lesson, we'll start modeling. 

 

 



LESSON 2: MODELING  

PART 1: The Side  

 

 

Open up ZM (ZModeler). First thing you want to do is load your blueprints. To do 

so, click on the corner button (as shown below) and go to 

Background>Image>Load Image... and a box will appear. Click Add... and load all 

your blueprints one by one.  

 
 

 

Pick the correct view for whichever window you opened it through (i.e. load front 

view blueprint in the "Front" window, side for right, top for Top...etc) and then 

click OK. Repeat for Side and Top view windows. We'll load Back view later when 

we need it. Your screen should now look something like below.  



 
 

 

When modeling, we should also refer to those photos (angled shots) of the car to 

develop a plan for how we're going model. Don't load them into ZM. Just refer to 

them. Here are some shots I found on Google Images:  

 

 
 

 

We'll focus on the side view window first.  

 



On the side toolbar, go Create>Surfaces>Flat. On the "Right" window, click and 

drag to make a rectangle and then release the mouse button. A box should appear 

indicating the name of the object you just created.  

 
 

 

Rename it if you want. Change Vertical Steps to 1, press OK and now your screen 

should look like this (except I changed the color of my lines to light blue because 

its easy to see, yours should be black):  

 
 

 

Now go to Create>Faces>Single and click once anywhere on the object you just 

created. You'll notice little red dots appeared at the intersections. Click once on 

the top-left red dot, then click on the dot just below it (middle-left) and then click 



some distance to the left of the object like so:  

 
 

 

Now we learn to move the vertices around. Go to Modify>Move, click on a vertex 

you want to move and drag it to another position. Keep moving vertices and 

creating faces until you get this:  

 
 

 



If you look at the toolbar at the top, you'll notice a group of buttons . 

The H and V are selected and because of this, you are allowed to move the vertices 

in any window ("Right", "Top", "Front"...etc) up, down, left and right. If you press 

the XYZ button that has the 3 arrows , it changes the group of buttons into this 

set --> . Whichever one button is selected, either X, Y, or Z, that’s the 

direction you can move your vertices, edges, faces or objects, no matter which 

window you use.  

 

Look at the Front view window or the Top view window and you'll notice that the 

vertices and faces you made in the Right view window are all in one line, in the 

center. Every time you make a new vertex, it is set at that center and you'll have to 

move it manually to its proper position (I'll show an alternate method next lesson).  

 

Right now, we want to move the faces along the X-axis so that they sit at the side 

of the Front and Top views. To do so, select the Rectangle selector tool found at 

the top ( ) and select all the vertices in the right view how you normally would 

with a lasso tool (click and drag to cover the vertices). All the selected vertices and 

surrounding faces will turn red like so:  

 
 

 

Now click on the X-axis button and also go to Modify>Move. In the Front view, 

hover for a moment, your cursor on any vertex (until you see the movement icon 

near your cursor, a plus sign with little diamonds on the edges) and then click and 

drag to move the whole thing to the edge:  

 

 



Before:                                                  After: 

 

   
 

 

IMPORTANT NOTE: Whenever you select multiple vertices or faces and want to 

change something about them, make sure the SEL button (look at toolbar on the 

right) is on. When moving a single vertex or deleting a single face or whatever, the 

SEL has to be turned off.  

 

To unselect all the vertices, just select some empty space.  

 

If you want, you can unselect the Rectangle selector tool. Then move back some of 

the vertices on the top so that they touch the edge of the roof in Front and Top 

views. You might want to do this in Right view while keeping your eye on the front 

and top views. Final Progress:  

 



NOTES:  

-Save your work often by pressing Ctrl+S.  

-At the top, go to Options>Settings>Open/Save and uncheck the “Enable Auto Saving” feature. I like 

this off because sometimes, if you carry on with a mistake and save, you can’t undo it. It’s better to 

save manually and often. 

  

Next Part, we finish up the body. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



LESSON 2: MODELING  

PART 2: The Rest of the Body.......or at least half of it  

 

Yes, there is a shortcut. Once we make half of the body of the car, we can duplicate that half, flip it 

and stick the two halves together. But first, we complete half the body. Let's go!  

Let's continue by making the top of the car. Go Create>Faces>Single and make a 

face in Top view like this:  

 
 

 

Notice where the last vertex is placed in the 3D, Right or Front views. Its placed on 

that center plane again. No matter, we'll make the whole top before we move 

around those vertices. So make every part of the car you can see in the top view 

like so:  

 
 

 

Select the vertices as circled above using the rectangle selector tool. Go to 

Modify>Move and select the Y-axis button. Move the selected vertices to their 



proper position using the Right view or Front view.  

 
 

 

Unselect those vertices and continue to move the other recent vertices to their 

correct positions. You may have to switch between the X, Y, Z and H+V locks to 

help you achieve this:  

 
 

 

Then complete the front and back views in a similar manner. When the new 

vertices fall on that center plane, move them out using the Z lock. To access back 



view, just click that corner button on any window, click Back, load the blueprint 

image for it and make those faces.  

 

 
TIP: I circled a few useful tools in the picture above. They help you to zoom in/out, pan view 

and things like that. I find them pretty annoying so what I do is I just use the mouse scroller to 

zoom and pan. How? Suppose you're zoomed in somewhere near the front of the car in top 

view and now you want to quickly view the back of the car. Use your scroller to zoom out until 

you see the whole car, move your cursor over the back of the car or wherever you want and 

then scroll again to zoom in there. I find this much faster than using the above mentioned 

buttons. Just thought I'd share this. 

 

 

Finishing the back will be a bit tricky since you'll be seeing all the faces you've 

made in the front and so it might confuse you. First, disable the "See-through" 

feature in Back view. Then, click on 2 vertices in the Right view window and click a 

third time in the Back view window.  

 



NOTE: Faces are one-sided, meaning that one side is solid gray and the other is transparent 

(you won't be able to see it). Whichever viewing window you finish the third click to make a 

face, that’s the view you'll be able to see the face (solid). 

 

 

Finish up the back view.  

 

TIP: Make one face, move its vertices to their correct places, make another face, move its 

vertices...repeat.  

 

 

By now, you must be thinking, "This is a pretty shitty model, what about all those details?”.... 

because I’m thinking the same thing. But I chose this route because it allows me to show you a 

very powerful method - BREAKING. (Thanks to Burner for introducing this method)  

 

You can break either edges or faces. Let me demonstrate the power of breaking. 

 

 

Let’s focus on the Right view window. Go to Modify>Break and either click the 

button circled in red (see below) or press 2 on your keyboard and then click once 

on your car to set it on "Edges" level. Then click on the two edges as shown below 

and vertices will appear there!  



 
 

 

Now go to Modify>Reorient and click the edge as shown below.  

 
 

 

To see how this works with faces, get into faces level by pressing 3 or clicking the 

"Faces" button and clicking once on your car. Go Modify>Break and click anywhere 

in the middle of any face and that’s where a vertex should appear. Reorient edges 

if necessary. Delete those extra faces by going to Modify>Delete and clicking on 

the faces individually. Make sure you are on FACES level when deleting the FACES.  



 
 

TIP: When breaking and reorienting edges, it may get a little confusing if you leave all the 

reorienting for later. So break a few edges/faces at a time, reorient them and repeat. It’s best 

to make a line of vertices (not on the same edge) all the way around the model and reorient 

nearby edges. Example:  

 

 

The idea now is to make edges so that they can define details of the car such as 

headlights, windows, wheel wells, curves, bumps ...etc. Continue to break, 

reorient, move and delete until you something like the picture below. Refer to 

your photos to see where you need to add curves and such details. You can add as 



much detail as you want, but I'm going to keep it simple.  

 

TIP: When moving vertices, make sure to keep the body smooth. Press W to turn off (if on) the 

wireframes and this view can help you determine how much to move the vertices to keep the 

body smooth.  

 

 

If you didn't understand the power of detaching, let me put things in perspective. We could 

have made all those details face by face. And every time you make those faces, the new 

vertices would have been placed on the center plane and you'd have to move them all to their 

proper places. This would take a long time and make it difficult to get a smooth shape. When 

you make a simple box (like we did in this tutorial) and start breaking to make faces, it 

preserves the shape you already have and you will only need to make slight adjustments to 

make a nice, smooth shape of a car.  

 

You should've noticed by now the blueprints aren't that accurate. Recall that when I 

mentioned the blueprints test, I said the positive results MOST PROBABLY (98%) indicate a 

good blueprint. There, no one can sue me now. Maybe we should have checked if the Front 

and Top views matched. I should also add to that test; in the Side view of the car you should 

be able to see full headlight and tail-light, some of the grille (front portion of car) and license 

plate area (back portion). I only hesitated to mention this before because the Top view 

showed that the Jeep has a pretty flat front and back so I thought it wouldn't show those 

details in Side view.  

 

But anyway, do the best you can. Keep those reference photos handy. 

 

 



Start making the bottom:  

 
 

 

Now, we make the wheel wells. Go to Create>Faces>Fan and make the faces like 

below:  

 



 

 

Then fill up the empty space with faces (Try using Create>Faces>Strip) and bring 

them away from the center plane to somewhere near the middle. Position those 

vertices correctly. Repeat for wheel wells near the front of the car.  

 
 

 

Pressing "Q" on your keyboard turns on/off the flatshading view.  

 

 
When flatshading is turned off, this view will represent what the car will look like if you decide 

to put it in Midtown Madness 2 or any other game. You see a lot of dark areas? We need to fix 

that by calculating normals. 



 

How to Calculate Normals:  

In vertices level, go to Select>All and right-click on any vertex. All the vertices in 

the object should be selected. Press "Space" on your keyboard to turn on SEL. 

Then go to Surface>Normals>Calculate and left-click once on any vertex. Most of 

the dark areas should have disappeared. Unselect all the vertices by going to 

Select>None and right-click on any vertex. If there is any darkness left, it should be 

around those faces that are nearly perpendicular or make other sharp angles with 

each other. To fix these dark areas, we need to detach some faces.  

 
 

 

How to Detach Faces:  

First, you should think for a moment about which group of faces you want to 

select. You want to select all the faces between two or more edges that you want 

to show up as sharp. In faces level, go to Select>Single and right-click a face to 

select it and repeat this to select all the necessary faces. Turn on SEL and go to 

Create>Objects>Detach and then left-click on any selected face. A box will pop up 

asking for the name of the new object you just created. Rename to "Surface2" and 

click OK. Unselect the faces by going Select>None and right-clicking on any 

selected face. Switch to Objects level (press 4) and also Select>None here. Now we 

have to join the objects back together again.  

 
 

 

How to Unite Objects:  

In objects level, Select>Single and select the two different objects by right-clicking 

on each. Making sure SEL is on, go Create>Objects>UniteSelect and left-click on 

any selected object. Rename the new object to "half-body" and click OK. 



Select>None on objects level to deselect everything.  

 

What’s the point of detaching and reattaching as we did? The objects are reunited 

but not the faces we detached earlier. Calculate normals again on the final object 

and......VOILA! We are done half of our model!  

 
 
 

My model here is pretty inaccurate since it’s meant to be a quick model. But it serves well enough to 

allow me to show you the basics. I hope your model looks better than mine.  

 

NOTES:  

-When making faces, try to develop a pattern so that all the triangles are pointing the same way or 

every other edge is nearly parallel. Do { |\|\|\|\|\|\|\| } instead of { |\|/|/|\|/|/|\| }. If you've 

already made the faces without pattern, just reorient that edge by going Modify>Reorient and clicking 

on the edge.  

 

-If nothing seems to be happening, check whether SEL is on or off. Remember, for single items 

(vertex, edge, face, object), SEL should be off and for multiple items (vertices, edges, faces, objects) 

SEL should be on.  

 

-If you make a mistake, quickly undo by pressing Ctrl+Z. Redo by Ctrl+Y.  

 

-When breaking edges, skip every other edge. The edge that you skipped is the one that will be 

reoriented....most of the time. This saves you polies.  

 

-If a view looks crowded due to all the faces and vertices from before, you can temporarily hide them. 

Select the vertices or faces and go to Display>Hide and click on a selected vertex or face. POP QUIZ: 

Will SEL be on or off?  If you want them back, go Display>Unhide. CAUTION: DO NOT HIDE ALL THE 

VERTICES OR FACES IN AN OBJECT AT ONCE!!! NEAR IMPOSSIBLE TO RETRIEVE. You may want save 

just before this procedure.  

 

-Go to Options>Normals and turn off Automatic Update. Otherwise, it can give you normal problems 

later on. 

 

That’s all for now I think. Next lesson, we learn to texture (color) the body. 



I apologize for the poor quality screenshots last time. I guess I got stingy over a few KBs but my 

upload speed is kind of slow or at least I don't like to wait for uploads. I realized, however, that it’s 

worth the wait to get better quality screenshots up, so I fixed this lesson. I may replace previous pics.  

 

************ 

 

 

 

LESSON 3: TEXTURING  

 

 

So we made our half-body last time. Before we duplicate it, lets texture (color) it first. To texture, we 

need some images (aka textures). These images must have square dimensions (32x32, 64x64, 

128x128, 256x256...) and they must be saved as .bmp or .tga.  

 

 

I've already prepared all the textures we'll need. You can just copy them since they satisfy the two 

conditions mentioned above.  

 

1.  2.  3.  4.  5.  6.   

 

 

Their names should be as follows:  

 

 

 

Keep these in a new folder named "TEXTURE" and have no intention to move the folder around to 

different places in the future. Might as well make a folder named "03 Cherokee" first and have inside 

it the .Z3D file, blueprints and the "TEXTURE" folder.  

 

 

 



In ZM, press "E" on your keyboard or click the button circled in red to bring up the 

Material Editor. There's only one material present at the moment and its called 

<default material>. Copy it 3 times to get a total of 4 copies.  

 
 

 

Choose one copy and rename it to "details". Also, load the "details" texture I 

provided for Primary Texture.  

 

Similarly for the other 3 default materials:  

Rename: black; Load the texture called "anything black" for Primary Texture.  

Rename: main body; Load "cherokee_green"  

Rename: wheels; Load "wheel"  

And then press OK.  

 

EDIT: It’s always a good idea to keep another extra copy of the <default material> just in case. We 

might need it later.  

 



 

Let’s texture the headlights first. Make sure to have Front view and 3D view active. 

Change another of the remaining windows to UV Mapper view.  

 

Select the faces (in faces level) in the Front view that make up the headlights.  

 
 

 

Now right-click on "half-body" in the objects list and go to Faces>Properties. A new 

box will appear. Select "details" from the list in the drop-down menu and then 

click OK.  

 
 



 

While Select>Single is on, also go to Surface>Mapping>Assign UV. Then click on a 

selected face and your UV Mapper view should look like this:  

 
 

 

Unselect all selected faces by going to Select>None and right-clicking on any 

selected face. Get into objects level by pressing "4" and turn off SEL. Hide 

Surface>Mapping>Assign UV and Select>Single and go to Modify>Move instead.  

 

Move your headlight faces in the UV Mapper view until they match the headlight 

texture. My headlight faces appeared to be a bit smaller than the picture of the 

headlights. Get into vertices level and move the vertices until they match the 

picture. If you move them one by one, you'll notice the vertices come apart, but 

don't worry about it. Whatever you do in UV Mapper view doesn't affect your 

model's structure in any way. Rather, it only changes the texturing scheme of your 

model...where the colors go. While texturing, refer to the 3D view to see if the 

textures have been placed the way you like.  

 
 
TIP: Use the rectangle selector tool to select all the vertices at an intersection point and then 

move them. 



Similarly, texture the other details.  

 
 

 
UV Mapping is easy if you remember the rules.  

 

The Golden Rules of Texturing:  

1. Load textures in Material Editor.  

2. Select>Single and select the desired faces.  

3. Check the properties of the newly selected faces and select the correct material 

for them.  

4. Making sure SEL is on, go to Surfaces>Mapping>Assign UV and click on a 

selected face in faces level. They will be transferred to UV Mapper.  

5. Unselect the selected faces (not in UV Mapper) and turn SEL off.  

6. Modify the object in UV Mapper view if it’s necessary to make a nice fit.  

7. Save your work.  

 
Next, we do the body. 

 

 

 

 

Select all the faces of the body. You many want to use the rectangle selector tool 

for some parts or select all faces (Select>All) and subtract (Select>Single and right-

click on selected faces) the headlights, windows, bottom and such. Change the 

material to "main body".  



 
 

 

When you get the faces into UV Mapper view, they will be larger than the texture. 

Go to Modify>Scale and make sure the H and V are locked (not X,Y, or Z). Click and 

drag on the object (in object level) to shrink its size and then move it on top of the 

texture.  

 
 

 

Onto the windows, wheel wells and bottom of the car. These will be colored black 

so change the material to "black". I "accidentally" forgot to subtract the bottom 

faces when texturing the main body so the bottom is also green. Before going to 

Surfaces>Mapping>Assign UV, go to Surfaces>Mapping>Reset UV and click on the 

selected faces. All previous textures will disappear from the selected faces. Now 

continue on with Surfaces>Mapping>Assign UV and you should get something like 

this:  

 



NOTES:  

-For a different lighting scheme in 3D view, you can go to Options>3D-View and turn on Specular 

Highlight.  

 

 

That’s all for now I think. Next lesson, we do some finishing touches to our model and maybe move on 

to other small but necessary objects. 

  



LESSON 4: MODELING REVISITED  

PART 1: Finishing Touches  

 

 

We left off last time texturing our half-body. It looks much better with the textures and colors but 

something seems to be missing and keeps the half-body looking very plain. We need to add the 

doorlines and other outlining details and there are a few ways of doing this.  

 

 

Method 1  

Draw the outlines in the textures so that when the textures are mapped, the outlines will fall into 

place.  

 

 

Method 2  

Make a thin line of polies where the outlining details should be and texture these polies black or 

similar dark colors.  

 

 

Method 3  

Carve out the outlines by making two or three thin lines of polies where the outlining details should 

be, detach the whole group of them or each strand, move the middle line of vertices/polies a bit 

inside and texture them the same color as the body.  

 

 

 

Method 1 takes too much effort and you don't get your bang for the buck most of the time. I've never 

tried Method 2 but it seems very easy and effective. Beginners should try it. I will show Method 3 

below because it looks the best, is 3D and that’s how I planned this tutorial. It will be very easy to do 

now because the texturing is already done. We just have to break, reorient and detach.  

 

 

 

 

Identify where all the door outlines are in the Cherokee. Don't forget to check the 

hood, roof, rear and near the windows. Using the Break&Reorient method, make 2 

thin lines of polies around these outlines (as shown on the blueprints).  

 



Before:  

 
 

 

After:  

 



 

 

Select the vertices in between the 2 thin lines of polies and move them inwards a 

bit. Then detach both thin lines from the rest of the body and reattach to the 

body. Calculate normals and you should get something like below.  

 
 

 
Actually, I think it would have been easier to detach the faces first and then move the vertices 

inwards. Then you continue by reattaching the faces to rest of the car and calculating normals. Sorry, 

but I just realized this as I was going along.  

 

 

Anyway, you can also make the handles using the breaking method, but I won't for this tutorial.  

 

 

We are almost ready to start the duplicating process. Check to make sure that everything is done on 

the half that we made so far. IF there is nothing else to model, nothing else to texture, we can go 

ahead.  

 



One minor thing to fix is the alignment of the vertices that are on the open edge. 

In either Top, Front or Back view and with the "See-Through" feature enabled, 

select the vertices using the rectangle selector tool. Be very careful and DO NOT 

select any vertices that are not on the edge (zooming in may help). Then go to 

Modify>Align>View and turning SEL on, click on a vertex in Right view. The 

selected vertices will snap to an imaginary plane. Then move the vertices to the 

very center (gray line) of the blueprint using either Top or Front view.  

 
 

 

 

 
Note: The following procedure may seem a bit tedious and pointless, but please bear (endure) 

with me. You will thank me later. 

We will need some light objects later on, so we can get some from our existing 

half-body model. First, detach the headlights. You'll see two objects in the Objects 

List; half-body and whatever you decided to call the headlights when you detached 

it. Right-click on the headlight object and go to Create Copy and name the new 

object. Now you have a total of 3 objects. Hide one of the headlight objects by 

clicking its name in the objects list and move the other one a little in front of the 

car (use Z-axis lock, in objects level).  

 



Repeat with the tail-lights to get a total of 5 objects.  

 

On the tail-light object that you moved some distance away from the main body, 

visualize where the reverse-lights, brake-lights and tail-lights of the real car go. To 

help you do that, you can click the corner button in the Back view window and go 

to Settings>Shade,Fill and turn on Solid.  

 

Break up the object's faces accordingly and detach the faces into the three 

categories. Don't worry about the messed up textures since we're going to re-

texture anyway. Also move each new object away from each other so that in Top 

view, you can see all the objects clearly by themselves and not half-hidden by any 

other object (except two mentioned below). This way, we can detach them easily 

later on.  

 

Also, make a duplicate of the headlight object that you moved away from the main 

body and move it even further away.  

 

So, to count again, you should have the following:  

 

-A main body  

-A headlight object (not moved from body)  

-A tail-light object (not moved)  

-A reverse-light object  

-A brake-light object  

-A tail-light (smaller) object  

-A headlight object (moved away)  

-Another headlight object (moved further away)  

 



Then attach all eight objects (use Select>All in objects level) together to make one. 

You can call this final object "right-half" or something like that.  

 
 

 

 

Create a copy of the "right-half" object and name the new object "left-half". Hide 

the right-half by clicking its name in the objects list. We are going to do 3 

important things only along the X-axis, so turn on the X-axis lock.  

 

1. Go to Modify>Mirror and click the left-half object (in object level).  

2. Go to Modify>Reorient and click the object.  

3. Go to Modify>Move and move the left-half so that the vertices on the open 

edge are at the center of the blueprints. Or, it’s also healthy to keep both the right 

and left halves a very small and EQUAL distance away from the center gray line.  

 



Then unite the two halves together.  

 
 

 

To get rid of the gap between the two halves, we need to select TWO AND ONLY 

TWO adjacent vertices and unite them. To do this, get into vertex level and go to 

Select>Quadr. Right-click and drag to make a rectangular selection around two 

vertices from the two halves that are next to each other.  

 



The two vertices will be selected. Then go to Create>Objects>UniteSelect and left-

click on one of the selected vertices. Both vertices will fuse into one.  

 

Be careful when you get to the edges that you've detached before. Where you 

think there is one vertex, in fact, there is two or more vertices. If you think you are 

selecting 2, in reality, 4 or more will be selected.  

 

How do you tell when there are multiple vertices? Hover your cursor over a vertex. 

If all the faces touching that vertex are highlighted, that means there is only one 

vertex. If some faces, but not all faces, touching the vertex are highlighted, that 

indicates more than one vertex there. 

 
 

 

FIX: Move the vertex lying on top or belonging to a certain face or edge first and 

repeat on left-half. Unite these identified vertices and repeat with extra vertices.  

 
 



 

 
 

 

Continue all the way around the model. You will need to use Top, Back, Bottom 

and Front views but not any of the Side views. It’s also a good idea to turn off the 

"See-through" feature. 
 

 

 

NOTES:  

-When you detach faces and calculate normals, the edges appear very sharp. What if you just want 

the edge to be pronounced with a definite shape but not appear as sharp as detaching will produce? 

Make a thin line or a few thin lines of polies over the edge and let them be very very close to each 

other, just as did when making the doorlines. But this time, don't do any detaching, just calculate the 

normals. The edge will appear sharp, but not too sharp.  

 

That’s all for now I think. Next lesson, we make wheels and name all the objects properly. That will be 

all for the modeling part. Then we will move onto putting the car in game. 

  



LESSON 4: MODELING REVISITED  

PART 2: The Object List  

 

 

We're pretty much done modeling our car and light objects. Now we move onto the wheels, shadow 

and bound. Don't worry, these are very quick models compared to the car.  

 

First, we'll make the wheel and copy it 3 times. I show 2 methods here, one simple and another fully 

3D. I recommend the beginner to make the simple wheel.  

 

Here we go!  

 

 

THE SIMPLE WHEEL:  

 

Find the "Cylinder" button on the toolbar at the top. In the Right view window, 

click once on the center of the front wheel and move the cursor away to enlarge 

the circular boundary.  

 
 

 

When it’s right, click again to set the radius of the cylinder and a familiar box will 

appear. Name it something like "wheel 1" and then you can change the Horizontal 

steps and Vertical steps to whatever you like. I set H-steps to 20 and V-steps to 0.  

 



 

 

Move some vertices around, detach some faces, calculate normals, texture it and 

you'll get something like this:  

 
 

 

That’s it for the simple wheel. More advanced modelers may want a more 3D 

shape though. So...  

 

 

 

THE 3D WHEEL:  

 

This time, use the "Tube" tool (found somewhere near the cylinder tool) to make 

the rubber tire first (textured black) and then make an "inner rim" (textured 

silver). Click once to initiate making of the tube, click a second time to set outer 

radius, click a third time to set inner radius and finally, click a fourth time to set 

width of the tube.  

 
 



 

Then create one spoke like so:  

 
 

 

Copy it four times to get a total of five copies.  

 

Go to Display>Local Axis>Move and move the local axis of the spoke to the very 

tip. Repeat for all spokes.  

 
 

 

It’s also a good idea to go Display>Place Axis and click once at the very tip of a 

spoke. You only have to do this once because there is only one global axis.  

 



Hide all the spokes except spoke #2. Then lock the X-axis and go to Modify>Rotate. 

You'll notice a certain toolbar at the top becomes active. Scroll on it until you get 

72 (because 360/5 = 72). This means that anything we rotate now will rotate in 

increments of 72 and only about the X-axis. So rotate spoke #2 until it snaps to the 

first position (72 degrees).  

 
 

 

Unhide spoke #3 and rotate it twice. Rotate spoke #4 three times. Rotate spoke #5 

four times.  

 
 



 

Unite all the spokes into one object. You can also unite the individual vertices as 

we did with the car. Put it all together and you have a 3D wheel!  

 
 

 

Now you can copy it 3 times and put the other wheels in place.  

 

When you name the wheels, they must have specific names.  

 

The front-left wheel will be called WHL0_H:m  

The front-right wheel will be called WHL1_H:m  

The rear-left wheel will be called WHL2_H:m  

The rear-right wheel will be called WHL3_H:m  

 

 

 

THE SHADOW:  

 

The shadow object is very self-explanatory - its the shadow of the car. It’s usually 

made up of 2 faces, sits at the very bottom and most of the work is done in making 

the texture. I use Photoshop to get the job done.  

 

 

First, open up the Top view blueprint and select the car. Create a new layer and 

paint the selected area black. Delete the background layer and you'll get 

something like below.  



 
 

 

You may decrease the opacity of the layer if you want a better shadow effect (I set 

it to 50%). Change the canvas size so that it’s square and save as .tga format. 

Remember to save it in the TEXTURE folder.  

 

In ZM, go Create>Surfaces>Flat and create a rectangle-shaped object in the Top 

view window. Bring up Material Editor, copy the extra <default material> and 

name it shadow. Load up the shadow texture and set the type to GLOWING (to 

allow transparent effects).  

 
 

 

Name the shadow object as SHADOW_H and texture it. Next up, the Bound.  



THE BOUND:  

 

The Bound is a very simple, exterior shell of the car. When the car is put in game, 

the bound is what will react with the environment. It is the solid part of the car 

while the body we made earlier is the cosmetic part. Bounds are kept as low-poly 

as possible (20-30 faces). The Bound should not cover the wheels of the car, just 

the body. There's no need to texture it since it will be invisible in game. The proper 

name for the bound object is BOUND.  

 

Here's an example of a bound:  

 
 

 

 

 

 

 



THE LIGHTS:  

 

We already have these objects as part of the body. Separate (detach) each group 

and name them as shown below.  

 
 

 

Actually, we should have textured them before we duplicated the body, but I guess 

I forgot. No worries, texturing isn't too hard.  

 

You can make the textures. For brake-lights (BLIGHT_L) and tail-lights (TLIGHT_L) 

paint a 32x32 canvas very bright red. For the reverse-lights (RLIGHT_L) and 

headlights (HLIGHT_L), paint a similar sized canvas a very light color like white or 

very light cream/yellow. I'll share my textures below.  

 

1.   2.  

 

You can also look in the ZModeler directory folder for light textures. The white one 

is called fxglow (or w_glow) and the red one is called fxglow_red (or r_glow).  

 

When texturing the light objects, set the type to "glowing" in Material Editor. After 

texturing is done, move the light objects very close the main body object so that 

they cover the original tail-lights and headlights that are part of the body.  



The HEADLIGHT0_H:m and HEADLIGHT1_H:m objects do not need to be textured 

nor do they need to be any particular shape. In game, these objects are replaced 

by glow balls at their centers. So move these objects close to the car but keep 

some distance.  

 

Now we need to make sure every object has their local axes centered, so go to 

Display>Center Axis and click on every object to accomplish this.  

 

Also make sure to calculate the normals for every object one last time.  

 

FINALLY, select all objects (Select>All in objects level) and move them up along the 

Y-axis until the shadow just sits on top of the horizontal (center) gray line seen in 

Right, Front and Back views. Save your work, we are done modeling!  

 
 
 

 



NOTES:  

-To put the car in game, you ABSOLUTELY NEED the Body, Bound, Shadow and Wheel objects. The 

Light objects are all extras and are not needed for the car to work in game.  

 

 

That’s all for now I think. Next lesson, we put the car in game. WOO! 

  



LESSON 5: PACKAGING  

 

 

We finished all the necessary modeling. Its time to put the Cherokee in game.  

 

 

First off, make five new folders and name them AUD, BOUND, GEOMETRY, JPG 

and TUNE. We already made the TEXTURE folder a while back so there's no need 

to make it again.  

 

 

Summary of the Folders:  

-AUD: Its where all the engine sounds and any other audio files go.  

-BOUND: Leave this folder empty. When we export the car from ZM, a file will 

automatically be placed in this folder.  

-GEOMETRY: Same as BOUND folder, leave it alone.  

-JPG: Some screenshots are placed here.  

-TEXTURE: All the textures used on the car go here.  

-TUNE: Contains all the text files responsible for the tuning/performance of the 

car.  

 

 

It might be a bit hard for us to make EVERYTHING by ourselves in all of these 

folders. In fact, the first game modifiers borrowed materials from the game 

itself....I think. We just need a sample car to get started.  

 

Go to www.mmarchive.com and download the Mazda RX-7 (VeilSide Fortune 

version) that was made by me (Silent1Unknown). Actually, here is the link to the 

car --> http://www.mmarchive.com/file_details.php?file_id=932  

 

It’s a Zip file. Double-click it to open up WinRAR and then extract it to desktop or 

wherever you like. You'll get a folder of the same name.  

 

When you open the folder, you see a text document called "Credits" and an AR file 

called "Mazda RX-7 Veilside Fortune". Usually, to get the car in game, you just stick 

this AR file into the MM2 directory. But today, we're going to see what’s inside it.  

 



The AR file can be opened with WinRAR. So, right-click the AR file, go to Open 

With>WinRAR archiver. Extract like before and you get a folder named "Mazda RX-

7 Veilside Fortune". Open it and you see six familiar folders; AUD, BOUND, 

GEOMETRY, JPG, TEXTURE and TUNE.  

 

Copy the contents of the AUD and TUNE folders and place them in the AUD and 

TUNE folders belonging to your Cherokee. You can also look inside of the JPG 

folder of the RX-7 to see what kinds of pictures you'll be putting in your Cherokee's 

JPG folder.  

 

OK, now we forget about the RX-7 files and folders focus our attention on the 

Cherokee files and folders.  

 

 

THE FOLDERS  

 

AUD  

In the Cherokee>AUD folder, there are more sub-folders which eventually lead to 

some files. Wherever you see "rx7vf" in the names of the files, replace only those 

five letters with "cherokee". Do this to EVERY file you find in the AUD folder. An 

example:  

 
 

If you ever want to put in your own engine sounds, make sure they have the same 

properties as these audio files here.  



BOUND  

Leave this folder alone. ZM will put a .bnd file.  

 

GEOMETRY  

Leave this folder alone. ZM will put a .pkg file and a couple of .mtx files. Don't 

worry, you don't need to know what they do or how they work.  

 

JPG  

In this folder, you want two image files that are saved as .JPEG (or .JPG or 

whatever it’s called) format.  

 

1. The first image has to be on a 640x480 canvas and it’s usually a photo of the real 

car (see example in the RX-7>JPG folder). When saving, save it as .JPEG and its 

general name is <your car's name>_show. In our case, it will be named 

"cherokee_show".  

 

2. The second image is a 219x69 JPEG image with a general name of <your car's 

name>_ulck. We will name our image "cherokee_ulck". This small image usually 

contains info like the maker of the car and maybe car specs.  

 

When you're done, your JPG folder should look something like this:  

 
 



TEXTURE  

We're done with this folder. I would just like to bring your attention to two 

textures we didn't use, namely, "cherokee_green" and "cherokee_red". Notice the 

names have the base "<your car's name>_color". You need this format when 

making multiple paintjobs. So in game, we'll have three colors available for our 

Cherokee; red, green and blue. I don't know what the limit is on paintjobs. I don't 

go beyond eight, although I've seen people offering eleven or more.  

 

 

And remember, these images are either .bmp or .tga and will have dimensions like 

...32, 64, 128, 256, 512 ...  

 

 

TUNE  

We copied the contents of this folder from the RX-7. There are 3 sub-folders here; 

"Banger", "Camera" and "Vehicle".  

 

1. Banger: Contains .dgbangeradata files. There should be one for every .mtx file in 

the GEOMETRY folder. Start replacing the "rx7vf" on all these file names with 

"cherokee".  

 

You can delete the _BREAK and _FNDR files here since we didn't make any 

breakable or fender objects for our car. But I'll discuss them later on, so you'll 

know where to look for these next time. Also, the .dgbanderdata files are editable 

with word processing programs like NotePad, WordPad, and Microsoft Word...etc. 

I recommend using NotePad....that’s if you ever need to edit these...which is like 

never....except maybe with _BREAK files.  

 

2. Camera: This folder also has a few files compatible with NotePad. These files 

contain information that deals with how you view you car in game. Too far, too 

close, too angled?....edit these files. Or you can get these from other cars that you 

liked. Or you can download MM2 Ultimate Tweaker do some.....tweaking of the 

cameras.  

 

Also replace the names here to "cherokee.whatever"  

 



3. Vehicle: More text editable files. Change the numbers around to fine tune your 

car the way you like. There are tutorials out there explaining what each heading 

means. I may add it to this megatutorial.  

 

Oh yes...I forgot....replace the names "rx7vf" here to "cherokee" as well.  

 

 

Back to the main TUNE folder, there are some files in addition to the folders 

mentioned above. Replace the "rx7vf" names with "cherokee as usual.  

 

Perhaps the most important file here is the INFO file. Open it up with NotePad and 

make the following changes:  

 
 

The Basename has to be a part of the filename of every file in all six folders. In our 

case, we chose "cherokee".  

For the Description, It will be name/title of the car as you see it in car selection 

screen in game.  

Colors: The titles of each paintjob. Doesn't have to be boring as red, blue, 

yellow....you could put Black Mica, Majestic Blue or whatever, doesn't matter the 

name. What matters is the order. So REMEMBER THE ORDER YOU PUT IT IN!!!  

Horsepower, Top Speed, Durability and Mass: These don’t have any effect on the 

car. In the car selection screen in game, these are the red bars that indicate how 

much your car has of each.  

UIDist: Enter a number between 1-10. It’s the distance or how far the car appears 

in the car selection screen.  

 

 



Replace the other "rx7vf" files here (TUNE folder) with the basename we chose, 

"cherokee".  

 

 

What about the BOUND and GEOMTRY folders?  

 

Open up your project in ZM. Make sure all the necessary objects are there, all 

normals calculated, all axes centered and all objects above the center gray line.  

 

 

Now, go to File>Export and a box will appear. Get into the GEOMETRY folder, 

name the file "cherokee" and save as .pkg.  

 
 

 

Hit Save and another box will appear. If we didn't have multiple paintjobs, we'd 

just click Export next. But we do have multiple paintjobs, three of them, so check 

the Multiple Colors (paintjobs) checkbox.  

 

 

Then, click the Remove button until the list on the far right is cleared. The one 

texture that we used in modeling the car is the "cherokee_green" texture. So, 

where it says [Replace suffix:], type in that box "_green".  

 

 

We have two colors remaining. Recall the order in which we put the color names 



in the INFO file (Green|Blue|Red). Green is already done. In the [...with suffix:] 

box, type in _blue and click Add to List. Then type in "_red" in the same box and 

click Add to List again.  

 
 

 

Finally, click Export. You may exit ZM.  

 

 

Now go to where the six folders are. Make sure all the "rx7vf" names have been 

replaced by "cherokee". Check that for every .mtx file in the GEOMETRY folder, 

there's a corresponding .dgbangerdata file in the TUNE>Banger folder. Delete or 

move the extra .dgbangerdata files (_BREAK and _FNDR files) someplace else. If 

you need extra .dgbangerdata files, copy and paste. When you're sure everything 

is perfect, select or highlight all six folders, right-click and go to Add to archive...  

 

 

 

A box will appear. The FIRST thing is to change the archive format to ZIP. SECOND, 

change the name (before the .zip part) to whatever you want. THIRD, change the 



zip to ar. Finally, click OK and you will get YOUR VERY OWN AR FILE!!!  

 
 

Clarification: Final name before pressing OK, should read "03 Grand Cherokee.ar"  

 

 

You know the rest, stick this AR file in the MM2 directory and have fun playing 

with your car.  

 

Here's a screenshot.  

 



As you can see, sometimes textures can mess up. I will fix this wheel texture 

problem by going into the TEXTURE folder and making a duplicate of the "wheel" 

texture. Then in ZM, open up Material Editor and replace the original "wheel" 

texture for the wheel material with the new duplicate. The problem fixed:  

 
 

 

SLAMMIN', HUH?!  

 

 

 

NOTES:  

-If you don't like the tuning, you can always change it in the TUNE>Vehicle folder or download MM2 

Ultimate Tweaker to make things easier.  

-If the car doesn't appear to be the right size, you can go back to the model in ZM, select all the 

objects and scale to whatever size is right. Make sure to put them back above the gray line.  

-For above mentioned edits to take effect, you'll have to make the AR file again.  

 

 

That’s all for now I think. Next lesson, I'll talk about some extras and maybe give some small tips. 

  



LESSON 6: THE EXTRAS  

 

 

Last time, we put the Cherokee in game and it looked very good. Now, we can make some 

improvements or enhancements.  

 

 

The first thing you want to do the first time you put a car in game is to check 

whether it’s the correct size or not. Different vehicles have different lengths in 

terms of side view. You want to look at the width of the car and how much of the 

lane it takes up in game because most vehicles have very similar widths.  

 

When I first put the Cherokee in game, I noticed its width was about a third (1/3) 

of lane width. That’s pretty small for a Jeep and compared to the default cars in 

game. Let's say we want to make the Cherokee bigger so that its width takes up 

two thirds (2/3) of a lane in game.  

 

In ZM, select all objects (in objects level), go to Modify>Scale, have the H and V 

locks on and turn SEL on. Then scale the objects while holding down the Shift 

button (on your keyboard) so that all objects are scaled equally in all dimensions. 

Scale the objects until they are about twice their original size. You may want to 

take the front view blueprint and enlarge it first to help with the scaling. Make 

sure the objects are still sitting just above the gray center line (if not, move them). 

Export and repackage into AR file.  

 

 

How to Make Glossy Textures  

Want to make your car glossy or shinier in game? You'll need reflection textures 

for that. You can find some reflection textures in the ZM directory or you can 

search on the forums or on Google.  

 

Check in my RX-7's TEXTURE folder and you'll see a texture named 

"reflexion03_bis". Copy it and paste into your Cherokee's TEXTURE folder. To apply 

it, open up Material Editor and check the "Reflection Map" option which is right 

under the "Primary Texture" option. Load the reflection texture "reflexion03_bis" 

and click OK.  

 



While we're on the topic of textures and folders, I'll add an important point made 

by an experienced modeler, Maxoff. He said, "I have just one small comment that may 

save hours of bug finding: use lowercase letters in names (materials in ZM, files and folders) 

because in some cases MM2 and ZM are case sensitive".  

 

 

How to Make Transparent Windows  

Suppose you decide to make the interior of the car and you want the windows to 

be somewhat transparent or translucent instead of the opaque black windows we 

made for the Cherokee. The fix is simple; in Material Editor, set the "Type" to 

"Glowing" and then change the opacity to your liking.  

 

Remember that this applies to the texture and therefore, whichever faces that 

contain this texture will become transparent. For our Cherokee, we used the same 

black texture to color the windows and the bottom of the car (chassis). So if you 

change this black texture to glowing and transparent, both the windows and 

chassis will be affected. If you plan to have transparent windows, keep aside a 

separate texture just for windows and other glassy faces like headlight and tail-

light covers.  

 

Also, there's a rule about transparent faces and what you see behind them. When 

you make some faces appear transparent, you will only see those faces that were 

created before the transparent faces were created. Suppose you made the interior 

after the windows (we made the Cherokee windows way back in lesson 2), you 

wouldn't be able to see it even if you make the windows transparent. To fix this, 

you can delete the current windows and make them again (it won't take too long, 

they're just windows) or you can detach the windows (you may need to make a 

new copy) and reattach to the body.  

 

 

How to Make Breakable and Fender Objects  

Breakables are objects on the car that fall off when hit in game. They usually 

represent side mirrors, fins, doors and the like.  

 

Note: Breakable objects do not appear shiny in game.  

 



In ZM, model the parts you intend to be breakable as separate objects (or by 

detaching). You can have maximum of eight breakable objects on any car. Their 

names:  

 

BREAK0_H:m -----> breaks when the car is hit on the front-left corner  

BREAK1_H:m -----> breaks when the car is hit on the front-right corner  

BREAK2_H:m -----> breaks when the car is hit on the rear-right corner  

BREAK3_H:m -----> breaks when the car is hit on the rear-left corner  

BREAK01_H:m -----> breaks when the car is hit on its front side  

BREAK12_H:m -----> breaks when the car is hit on its right side  

BREAK23_H:m -----> breaks when the car is hit on its rear side  

BREAK03_H:m -----> breaks when the car is hit on its left side  

 

When you export, there will be a .mtx file for every breakable object placed in the 

"geometry" folder. Remember to add a corresponding .dgbangerdata file in the 

"tune>banger" folder. See my RX-7's "banger" folder to see how to name the 

.dgbangerdata files.  

 

You can adjust the sensitivity of the breakable object in the .dgbangerdata file by 

specifically changing the mass or impulse limit numbers. You can also find the 

center of mass and similar info about your breakable object in a text file in the 

"geometry" folder.  

 

 

Fender objects rotate when the front wheels turn and to the same degree. They 

usually represent wheel covers (like in the Panoz default car) or brake discs and 

calipers. I used them to try to make spinner rims on my RX-7 but it didn't turn out 

too well. (BTW, you can get the RX-7 without spinner rims from www.mm2x.com).  

 

You model fender objects separately or detach them from the main body later on 

just like for the breakables. As far as I know, you can have a maximum of two 

fender objects on a car. Their names:  

 

FNDR0_M:m -----> placed near the front-left wheel....usually  

FNDR1_M:m -----> placed near the front-right wheel  

 



But these don't work by themselves for a reason unknown to me. So make 

duplicates and name them FNDR0_H:m and FNDR1_H:m and then export. Also 

add the necessary .dgbangerdata files (which you probably won't need to edit).  

 

Sorry for the confusing information, but I just recently tried fender objects for the 

first time and hurriedly looked up some random posts for info. You can do some 

research on the forums to help you understand better how fender objects work.  

 

 

Night Textures  

These textures appear on the car only at night and are invisible during the day.  

 

Suppose you want the car to appear black in daylight, but dark gray at night. Take 

that texture of the car that is black and duplicate it and rename it the same as the 

black texture, but this time add the suffix "_ni" (Example: cherokee_black -----> 

cherokee_black_ni). In this new duplicate texture, change the black color to dark 

gray.  

 

You don't have to do night textures on the body only. This method can be applied 

to make night-time neon underglows or anything else you like.  

 

 

The Shadow  

Instead of the boring old half-transparent shadows normal cars have, you can 

change the look of the shadow texture in Photoshop so that it appears the car has 

neon underglow. On top of the normally black texture (on a new layer), make 

some lines or thin rectangles filled with the color of your choice. Right-click on the 

layer, go Blending Options and add an Outer Glow. Play around with the numbers, 

something something, and you'll get some nice underglows on the shadow. Then 

texture the shadow object with this texture. See my RX-7 textures for examples.  
 

 

 

That’s all the extras I know of at the moment. There's also a way of adding animated textures and 

extra wheels but I haven't learned those yet. In the next and hopefully final lesson, I'll go over some 

tips on how to improve your modeling. 

  



LESSON 7: MODELING REFINED  

 

 

There's not much to teach in this final lesson. I just introduce some ideas you can use to help you 

improve your modeling.  

 

 

If you look back at the Cherokee I made for this tutorial, you should know that it’s 

not the best model in the world. It was a very quick model and its purpose was to 

show the basic methods and principles of modeling in ZM. Ofcourse, you don't 

want to stay at the basic level and make boxy cars forever. You want to improve 

with every model you make. You want to learn to make smoother, more efficient 

shapes.  

 

So what makes a model smoother? Increasing polycount is only half of the answer. 

Poly-placement is a more important factor. A model with few but organized 

polygons will look much better than a high-poly model that has disorganization. 

Furthermore, when extruding (moving vertices to achieve 3D shape), move the 

vertices little by little to get smooth curves. You don't want to make large jumps or 

make sharp angles. Just keep it slow and gradual. And that’s what smooth really 

means, gradual.  

 

 

An example of good poly organization:  

 
 

 



An example of poor poly organization:  

 
 

 

How does adding more (organized) polies help? It allows more opportunity to 

make gradual changes and therefore smoother objects. Observe:  

 
 



Exercise 1:  
First, draw a triangle having all three sides equal in length. Then make a square 

(rectangle with equal sides). Then make a pentagon of equal sides. Then hexagon 

(6), heptagon (7), octagon (8)........What shape do you think you'll eventually get if 

you could continue to infinity? (Answer: Circle)  

 

We know that a circle has a very smooth curve. As you go backwards from the 

circle, decreasing the number of edges, you can see it as the circle losing its 

smooth curve (or the curve is getting bumpy) every step of the way until you 

recognize the common shapes.......hexagon, pentagon, square, triangle, angle, line.  

 

 

 

Exercise 2:  
Grab a picture of a car (from magazines, internet or wherever). I'll use this:  

 
 

 

Imagine cutting the car in half and draw on the car where that cutting line would 

appear like so:  

 
 



Make a few more cuts until you reach the edge of the car. You don't have to be 

perfect.  

 
 

 

Now make some horizontal (XZ-planes) cuts along the flat parts of the car.  

 
 

 

Finally, make some XY-planar cuts.  

 
 

 

 



I added diagonals to all the rectangles in two strips that go along the length of the 

car. These would represent polygons in ZM. That’s the idea of organized polygon-

placement, they are basically strips of rectangles (two polies each) that run along 

the length of the car. You can easily make such rectangles and move the vertices 

to their correct locations.  

 
 

 

What about the non-rectangular components like the weird curves? Fill them in 

with multiple triangles!  

 
 

 

Make more polies around the details. Keep breaking down weird shapes into 

rectangles and then into triangles until you see nothing but triangles. Curved parts 

of the car will have more polies ofcourse.  

 



Just like how you drew all those polies by hand, that’s generally how you would 

make a car in modeling software such as in ZM. Except that ZM has shortcuts such 

as breaking, reorienting, creating strips and fans....etc.  

 

Now, I think you can understand why you wouldn't start making polies like this:  

 

 

 

So practice this exercise whenever you see a photo of a car in a magazine (or on 

the net). It'll only take a few minutes of your time, but will teach you a lot about 

space, geometry and poly organization. You can also do this right before you start 

modeling a car to sort of plan ahead and give yourself an idea of how you want to 

approach that specific car. For a low-poly car, make fewer cuts that are spread 

further apart. For a high-poly car, you would need more cuts that are very close to 

each other. Also, you don't strictly have to make cuts along those planes (XY, YZ or 

XZ) all the time, you can make cutting lines pass over nearby details if that's more 

efficient.  

 

 

That’s all I can tell you about modeling. I'm pretty much a beginner myself. I've 

only made 4 cars so far. But if you look at my progress, you'll see that I improved 

from model to model. Note the changes in each wireframe.  



 

 

 

 

 



 

 

 

 
 

 

 



What did I do to improve my modeling? I studied wireframes. I visited other 

forums and sites (SMCars, MM2C, NFScars, GTA, Google...etc), collected a lot of 

pictures of the wireframes of other people's best works and stared at them all day. 

I looked for patterns and noted how the experts placed their polies to make 

certain features of their models. I suggest you do the same. From now on, if you 

see a good wireframe picture on the net, save it to your desktop and refer to it 

often. Then try to repeat the patterns on your own models. The more you practice, 

the more improvement you'll see in your modeling.  

 

 

And if you ever run into problems, have any questions or want some help with 

anything, sign up on the MM2C Forums and post your needs. There are some 

really brilliant people there who can help out. It'll also help to liven up the place.  

 

Also, if you think your work is good enough and is worth sharing with others, you 

can sign up at MMArchive or MM2X and host your car there. 
 

 

 

Well, that’s it for this tutorial. I hope you found it useful. Farewell and enjoy modeling!  

 

 

 

 

 

 

 

NOTES: 

 This tutorial was originally written over multiple posts on MM2C’s “The Bodyshop” forum. Here is the 

link to it � http://forum.mm2c.com/viewtopic.php?t=14160  

The images shown in this PDF version have lost quality and clarity due to shrinking to fit and 

converting to PDF from DOCX. For this reason, I have added the original pictures in the total package. 


